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1

Purpose

I am writing this document for a few reasons. Firstly, the mail server was never
documented. Hence, I decided to take up the writing of this “User’s manual”
which would soon be followed by the “Administrator’s guide”. Secondly, I found
that not every one is making proper use of the facilities provided. Hence, I
want to make every one aware of all the features that our installation provides.
Thirdly, I would like to bring to your notice some policies that the Networking
Group has framed, about the use of IIIT Mail. Since there is a hairline difference
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between a feature and bug, I would like you all to know some things, that I
have been reported to, as being bugs, but actually, are not. Lastly, I would like
to present my personal views about mailing in general, and also spread some
awareness regarding the use of PGP to sign and encrypt mails.
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Overview

This document is the official “User’s manual” created for the reference of the
IIITA community. It presents information about the mail server configurations,
and provides some settings that might help you use the facilities in more effective way. Although I might talk about many things, like the webmail interface,
Mail Client configurations, etc, I do not want to supersede the respective documentations of those software. This document is just to provide a Quick help.
Although most of the settings, tips or tweaks mentioned here generic, they are
written keeping the IIIT server in mind, and I disclaim any loss to any one else,
due to use or inability to use the stuff mentioned herein. While talking about
the effective mail usage and PGP related things, I would be presenting my personal views, and you are free to have contradictory ideas, and even continue
to have them. After reading this document, you would be knowing answers to
questions like “What can I do with the IIIT Mail, and how I can do it?”, “What
mailing practices are recommended?” , “What am I not supposed to do?”, etc.
Hence, I recommend that all the users of IIIT Allahabad must go through this
document at least once.
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About the Mail Server

The Mail Service uses four Servers.The Mail software runs on a dual Xeon
2.4Ghz processor with SCSI disks and DDR RAM, while other three(with the
same configuration) has mailboxes of the users.The system software knows where
to deliver the incoming mail.They have a three level stable power supply. They
run the SMP 2.4.20 kernel that ships with SuSE 9.1. The mail software is
basically a QVCS installation. We use Qmail 1.03 as the MTA. The POP and
IMAP is provided by CourierIMAP version 2.0. Vmailmgr is used to provide
virtual hosting, and that package does the user account management. The
antivirus installed, that looks up viruses in attachments, is “clam antivirus”.
Spamassassin is used to mark SPAM. Squirrelmail, as you all know, provides
the web interface to emails. The data on the server is backed up regularly. If
all this seems to be a jargon, then simply speaking, our mail server runs very
good software, on a very good hardware, and hence, is very reliable.
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4.1

About your email account
Userid

Your userID is decided on the basis of the name that has been registered in
the office. We use the template of “ alastname batch” for the same, where
“a” is the string of first letters in the rest of the words in your name. For
example, my name has been registered as “ Pankaj Kumar Trivedi”, and hence,
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my ID is “pktrivedi b04”. PHD and research students have “ prs” in their email
IDs. Please note that your username is different from the userID. Because
we host virtual user accounts, the username must mention what domain the
userID belongs to. Hence, the username is the entire email address, like “
userID@iiita.ac.in”. To log in via web interface, your userID would work, but
to configure clients, etc, you need to give the username.

4.2

Aliases

Your user ID can not be changed, but for the exceptional cases like the change
of batch. However, you are allowed to create at most three aliases to your
account. You can receive and send mails using your aliases, however, they are
not different mailboxes, and you can not login using an alias.

4.3

Passwords

Your passwords are stored encrypted on the server. Also, only the mail administrators have shell access to that system, so that adds to the security of
your account. However, because the passwords are not plain text, in case you
lose it, it can not be retrieved back. You could, however, send a mail to the
“mailadmin at iiita.ac.in” asking the password to be reset. You will be issued a
new password then.

4.4

Mail Quota

There are two limits to your mailbox size. The “soft” and the “hard” limits, of
225 and 250 MB each. Once your mailbox size reaches 225 MB, it enters into a
“SOS” stage. In this stage, you can not receive mails larger than 1 MB in size.
Also, for every new mail that you receive, you would get a warning message,
saying that your mailbox is nearing quota overrun. Once the mailbox reaches
its hard limit, all mails coming to you would bounce. This time, however, the
server would feel “tired” of warning you since so long, and would cease to send
any warnings.
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IIIT Mailing Lists

No. We have a mailing list, one for every batch of students, and one for the
entire community. For the batch mailing lists, the message would drop into the
mailbox of all students of that batch. Such lists could be used to communicate
noticelike messages. The addresses of these lists are put up in the global address
book in the webmail interface. Mailing lists can be POST moderated. In such
a situation, designated moderators need to screen the messages before they can
reach all the recipients. Unwanted messages can be rejected. If a batch wants
that its mailing list must be moderated, send a mail with IDs of at least 4
students from the batch (as wanted moderators) to mailadmin. However, note
that, any message, however urgent, would not be sent unless some one moderates
it.
Mailing Address of mailing lists have changed. For exmaple mailing list for
our batch is now btech2002 at lists.iiita.ac.in. Except for alumni and everyone
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mailling list all lists are now unmoderated. However, sender will be required
to send a confirmatory message before the mail goes for the final distribution.
Following are the address of the mailing lists. Please append @lists.iiita.ac.in
alumni – IIIT Alumni
everyone – People currenlty staying in IIIT
faculty
staff
bi2002,bi2003,bi2004,bi2005
btech1999,btech2000,btech2001,btech2001jan,btech2002,btech2003
btech2003jan,btech2004,btech2005
is2002,is2003,is2004,is2005
mba2004,mba2005
pgd2004,pgd2005
se2004,se2005
wcc2002,wcc2003,wcc2004,wcc2005
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The Circular Mailing List

Messages sent to the circular mailing list reach all the users in IIIT community.
This list is postmoderated. A policy has been decided as to what kind of mails
shall be allowed to be posted on the list. No one should post messages not falling
in the categories below, because it would not be accepted by the moderators.
The acceptable categories are:
1. Notices that are eligible to be posted to “all notice boards”. These can
be posted only by the Office, Staff, Faculty, and representatives of official
teams of students(like webmaster, clubs).
2. Notices from Office, staff, faculty, and students, that contain information
intended to benefit every one in the IIIT community. (e.g. information
about subscriptions like ACM).
3. Please note that messages with large attachments will not be accepted to
be posted to the circular list. In case you want to put a large attachment,
contact the webmaster for a place for the same on the web server, and
give the link for the same in the mail to be sent to circular@iiita.ac.in .
4. Also note that notices intended for just a single batch, if posted to this list,
will not be accepted. Please use the batch address to post those messages.
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The Web mail interface

Our server runs the Squirrelmail webmail client. It was chosen because it has
a great IMAP support. The best thing about squirrelmail is its plugin based
addon system. Both the core and the plugins are well maintained. When the
mailadmin feels that a new feature must be added to the existing mail, he just
looks up the squirrelmail site, and downloads the plugin, and installs it. I am
not going to write more about squirrelmail, because it has an excellent documentation, which, you can access from its site, or by clicking the “Help” link
4

while reading mails. However, I want to bring out some important issues related
with the webmail.
1. We all know that transfers that take place over HTTP are simple plaintext.
Hence, any system that falls onroute from your place to the mail server,
can read what you are transferring, which includes all your mails, and
even passwords. Password during logging in is transferred over plain text.
If you want the transaction to be secure, click the “ Use Secure Login”
link on the home page. SSL encrypted Login will do the needful.
2. The default configuration of the interface is mostly suited to all the people.
In case you want fancy colors, fonts, you can change the default preferences. The “Folder Size” link on the left page will let you know the size
of your mailbox. Keep checking this so as not to run out of space.
3. There are some features that I would like to make you aware of. They are
enumerated below.
4. You can use mail filters to filter out SPAM. To do this, create a new folder
“SPAM” from the Folders menu. Then go to Options Message Filters.
Select “Only Unread Messages” in the combo box, and click “save”. Next,
Click New. Select “Headers” in the from options, and in the content box
type “XSpamStatus: Yes” . Move to folder SPAM. Click Submit. All
further incoming spam will go into the SPAM folder.
5. While reading a mail, you can import the sender’s address into your address book by clicking the “Add to Addressbook” link.
6. You can check spellings while composing mails. However, if you select the
“HTML mail” format while sending, the spelling check is disabled.
7. The following things were reported as bugs to me. Please note that they
can not be considered as bugs. Here is what I have to explain :

Bug Reported
I can add a new identity in the squirrelmail preferences, by specifying any
email address in the “from” field. It is thus possible to send mails by
faking some one’s identity

My Explaination
It is trivially easy to forge mail headers. If you need squirrelmail to do
that, you seem to be a newbie. One can send fake mails right from the
command prompt, by establishing SMTP session, or by using email clients
at the remote system. However, in order to send mails to destinations
outside IIITA, you need to use SMTP authentication, and then, the mail
“full” headers will show the name of actual sender. However, Sending fake
mails using the IIITA server is not permitted.
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Bug Reported
Having Logged out, I clicked the Back button of the browser, and the mail
box opened again.

My Explaination
There is a problem with some browsers, in the sense that they cache the
pages visited. When you click the back button, instead of querying the
mail server (which would say that the user has logged out) the browser
displays the page from its cache. Hence this seems like a bug. You are
recommended to close the browser window after signing out.
8. I recommend you NOT to use the web mail interface. I might sound queer
when you read this, because my login count on the web mail itself was an
order greater than the average, while I wrote this document. I admit that
my count is high, because I have to log in and out many times while I am
constantly testing the updates in the mail client. In my opinion, the web
mail must be used only under two circumstances.
(A) You do not have a permanent system to work on, and
(B) ou are going to be out of the campus for long time and want to check
mails from a remote place, where you can not set up a mail client. For
several reasons, like convenience, security, features, etc., I recommend you
to set up email client on your system and use it for the mail transactions.
However, note that, despite configuring mail clients, you need to open
webmail for changing passwords and checking mailbox sizes.
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Configuring Mail Clients

Step by step how to for configuring mail clients was long waited by many
people. However, this release contains configuration help for only two
popular mail clients. People who have configured other clients can contribute their howto for the next release of this document, by sending it to
mailadmin.

8.1

Windows

Outlook Express
Start Outlook Express
Go to Tools ⇒ Accounts.
Click on Mail tab.
Add ⇒ Mail Display name: Enter your name here.
Email address: Enter your full emailaddress (eg. test@iiita.ac.in)
My incoming mail server is a: Select IMAP from drop down list.
Incoming mail server: mail.iiita.ac.in
Outgoing mail server: mail.iiita.ac.in
Account name: Enter your full account name (“ test@iiita.ac.in” not just
6

“test”) .
Password: You can put it here itself and check Remember password Or it
will ask for it each time you connect to the IIITA mail Server.
Do not check the box Log on using Secure Password Authentication (SPA).Our
mail server does not support SPA..
The basic configuration is done.
click Tools ⇒ Accounts.
In the Accounts window click the Mail tab.
Click once on the existing Post Office entry to highlight it and then click
the Properties button. This will bring up the Properties dialog box for
the existing entry. Select the check boxes “ This server requires SSL” for
SMTP and IMAP. Click on the IMAP tab and enter inbox into the Root
folder path: field and then click on Apply or OK to accept your changes.

8.2

Linux

KMail
Start KMail.
Select “Configure Kmail” from the Settings Menu.
In the “Identities” frame, Click the “New” button.
Enter your details in the General tab, and click OK.
Select the default identity, (one that existed from beginning) and remove
it.
Come to the “Network” frame.
In the “Sending” tab, click the “Add” button.
In the general tab, give following settings
Name: IIITA
Host : mail.iiita.ac.in
Select “Server requires authentication”.
Enter the Login name, and password, and optionally save it.
Remember that login name must have user id@iiita.ac.in format.
In the Security tab, click “Check what server supports”.If you get a certificate warning, accept the certificate for ever. Then click OK.
Come to Receiving tab.
Click the Add button. Select IMAP from the list.
In the general tab, enter the following settings.
Name IIITA
Login user id@iiita.ac.in
Host mail.iiita.ac.in
Optionally, save the password.
Enable interval mail checking, if you like.
In the Security tab, click “What the server supports”. Then click “OK”.
Click OK to close the configuration window.
Select File ⇒ Check Mail In ⇒ IIITA
Select “Configure KMail” from settings Menu, again.
In the Identities frame, select your identity, and click “Modify”.
In the “Advanced” tab, you have to change the Sent and Drafts folder.Instead
of the current one, select the one that is shown as a sub folder of the IIITA
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mailbox. It will be slightly indented. Select “Sent” for sentmail folder and
“Drafts” for Drafts folder. Click OK.
Come back to the Network frame. Open the “Receiving” tab. Select your
identity and click “Modify”.
In the general tab, change the “trash” folder to the IIITA trash folder. It
will be shown a little indented to right, in the list. Click OK.
Close the configuration window, by clicking OK. KMail is successfully
configured.

9 What you are absolutely recommended to
do
(a) Stop using Web mail. Use any mail client of your choice. I prefer
KMail myself.
(b) If at all, you need to use the Web mail, use it in the secure mode,
by clicking the “ Secure login” link. You mi ght get a certificate
warning, Accept the certificate.
(c) Do not abuse. Sending fake mails, or sending large number of unsolicited or junk mails is not permitted. User accounts detected to have
abused could be disabled with or without warnings. When a mail account is disabled, it not only disallows you from signing in, but you
also stop receiving any incoming mails, till it is enabled again.
(d) When you configure identities in your mail client, make sure that
the “ From address” is either your username or an alias. You can,
however, change the “ ReplyTo” address to any thing that you want.
Note: If you have purchased a domain, you can set the “from” field
to at most one account of your domain, but you need to contact the
mail admin and tell him the email address that you would be using.
(e) Keep the size of your mailbox lesser than 15 MB. Above 15 MB, new
mails of size greater than 1 MB will not be received.
(f) Do not send Read Receipts to all mails, unless you know who the
sender is. Spammers use read receipts to verify your email address.
(g) Do not delete mails marked as “SPAM” without looking at them.
Some times, important messages get marked as spam.
(h) Switch on the Vacation Autoresponder while going out for a long
time. More importantly, switch it off, when you come back.
(i) Keep your system well protected from viruses. Do not open attachments from mails that come from strangers, or are not expected at
all. Mass mailing viruses, when enter the network, multiply like any
thing. Cooperate to keep them out of the IIIT network.
(j) Start using PGP with mails (Discussed in the sections below).
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